Слова в строке отделяются одним символом пробела. Определите количество слов, содержащихся в данной строке

Количество слов будет на единицу больше количества пробелов, если пользоваться традиционным алгоритмом.

1. Традиционное решение.

// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
var
  s:string;
  i,k:integer;
begin
  Write(Введите строку: ); Readln(s);
  k:=0;
  for i:=1 to Length(s) do
    if s[i]= then Inc(k);
  Writeln(Количество слов равно ,k+1)
end.

Результат выполнения программы:
Введите строку: А роза упала на лапу Азора
Количество слов равно 6

2. Решение срeдствами PascalABC.Net 3.1

// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
  var s:=ReadlnString(Введите строку:);
  Writeln(Количество слов равно ,s.ToWords.Count)
end.

Результат выполнения программы:
Введите строку: А роза упала на лапу Азора
Количество слов равно 6

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку