Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.
Программа должна вывести двоичное представление переданного её числа.
Примеры
входные данные
5
выходные данные
101
входные данные
-14
выходные данные
-1110
Var n:integer; s:string;
procedure bin(n:integer; var s:string);
var i:integer; c:string;
begin
s:=;
while n>0 do
begin
STR(n mod 2,c);
s:=c+s;
n:=n div 2;
end;
end;
begin
write(n=); readln(n);
bin(abs(n),s);
if n<0 then s:=-+s;
writeln(s);
end.
Пример:
n=-14
-1110
Оцени ответ
