ГДЕ ОШИБКА В КОДЕ? ЯЗЫК СИ.
#include
#include
int main()
{
system ("chcp 1251 > nul");
printf("/n Условие: Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух.");
int a,b,c,d;
printf("/n/t Введите 1 число -> ");
scanf("%i",&a);
printf("/n/t Введите 2 число -> ");
scanf("%i",&b);
printf("/n/t Введите 3 число -> ");
scanf("%i",&c);
printf("/n/t Введите 4 число -> ");
scanf("%i",&d);
int chislo(int a, int b)
{if (a>b) return a; else return b;}
printf(chislo(chislo(chislo(a,b),c),d));
return 0;
}
В printf не задана строка формата вывода. Сначала должна быть строка, типа printf ("%d" , chislo..........)
и ещё не указано что #include. Компилятор не поймёт, наверное, если в директиве #include ничего не указано.
Оцени ответ
