Напишите программу(НА ПИТОНЕ), которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.
Программа должна вывести двоичное представление переданного её числа.
Примеры
входные данные
5
выходные данные
101
входные данные
-14
выходные данные
-1110
(НА ПИТОНЕ!!!!!!)

# Как я понял, для отрицательного числа просто добавляется
# знак -

def IntToByte(x):
    n = "" if x>0 else "0"
    while x > 0:
        y = str(x % 2)
        n = y + n
        x = int(x / 2)
    print (n)
a = int(input())
if a>=0:
    IntToByte(a)
else:
    print(-,end = "")
    IntToByte(-a)


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку