Дано N случайных чисел в диапазоне от -3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.

Var a,i,n,k : integer;
Begin
  randomize;
  Readln(n);
  for i:=1 to n do begin
    a:=random(7)-3;
    if a=0 then k:=k+1;
    writeln(i, число = ,a);
  end;
  Writeln(Количество 0: ,k);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку