ПЛАЧУ МНОГО БАЛЛОВ! Составьте программу для определения количества четных и нечетных цифр в записи данного натурального, пятизначного числа. (В обычном паскале)

Var a,c,n : Longint;
Begin
  Readln(a);
  c:=0; n:=0;
  While a>0 do
  Begin
    If a mod 10 <> 0 then
      If Odd(a mod 10) then Inc(n) else Inc(c);
    a:=a div 10;
  end;
  Writeln(Чётных: ,c);
  Writeln(Нечётных: ,n);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку