1) К нам пришел заказчик. Он является судьей в баскетболе и попросил написать программу, которая бы считывала результаты каждой из 4-х четвертей баскетбольной встречи и говорила какая команда победила.
пример ввода:
26 : 17
13 : 15
19 : 11
14 : 16
ответ:
победила первая команда
предусмотреть возможность ничьи
Срочно!

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var s1:=0;
  var s2:=0;
  for var i:=1 to 4 do begin
    var a:=ReadlnString(Счет встречи № +i).ToWords(Arr(:, ));
    s1+=StrToInt(a[0]); s2+=StrToInt(a[1])
    end;
  if s1>s2 then Writeln(победила первая команда)
  else
    if s1=s2 then Writeln(ничья)
    else Writeln(победила вторая команда)
end.

Тестовое решение:
Счет встречи № 1 26:17
Счет встречи № 2 13 : 15
Счет встречи № 3 19: 11
Счет встречи № 4 14 :16
победила первая команда

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку