Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n.
Если можно побыстрее, а то на завтра нужно.

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln(s=,Range(ReadInteger(n=),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write(n=); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln(s=,s)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку