Помогите пожалуйста)
Нужно сформулировать условие задачи, которое решается в данной программе:
PROGRAM
Uses Crt;
Var N: integer; S: Byte;
Begin
Write(Введите натуральное число:); ReadLn(N);
S:=0
While N <> 0 Do
Begin
S:= S + N mod 10; N:=N Div 10
end;
WriteLn(S=,S:4);
END.
1. Ошибка в коде: после S:=0 нет " ; "
2. Формулировка может быть такой:
Напишите программу, которая для натурального числа N получает сумму его цифр.
Программа на вход получает одно число N - натуральное. На выходе получаем одно число S - сумма цифр числа N.
Оцени ответ
