Написать программу которая содержит подпрограмму-функцию которая вычисляет кол-во положительных элементов одномерного массива 10 компонентов вещественного типа.
(РЕШИТЬ НА БАЗЕ PASCAL 7.0)
Type tMas = array[1..10] of Real;
Var m : tMas;
i : Byte;
Function OddFunc(b : tMas) : Byte;
Var j,n : Byte;
Begin
n:=0;
For j:=1 to 10 do If b[j]>0 then Inc(n);
OddFunc:=n;
end;
Begin
For i:=1 to 10 do
Begin
m[i]:=-100+Random(200);
Write(m[i], );
end;
Writeln;
Writeln(OddFunc(m));
end.
Оцени ответ
