Последовательность состоит из натуральных чисел и завершается числом 0. Определите, сколько элементов этой последовательности равны ее наибольшему элементу. решите на питоне 3 и пожалуйста без массивов
можно с любыми циклами даю много балов и всем кто ответит скажу спасибо

a = int(input())
Max = a
n = 0
while a != 0:
    if a > Max:
        Max = a
        n = 1
    elif a == Max:
        n += 1
    a = int(input())
print(n, - , Max)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку