ПОМОГИТЕ С ИНФОРМАТИКОЙ 10 КЛАСС
Алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на разность большего и меньшего до тех пор, пока одно из них не станет равно нулю; тогда второе и есть НОД. Напишите программу, которая реализует этот алгоритм.
Function NOD(a,b : Longint) : Longint;
Begin
If (a mod b)=0 then NOD:=b else Nod:=NOD(b,a mod b);
end;
Begin
Writeln(NOD(9,6));
End.
Оцени ответ
