Напишите программу в PASCAL, которая проверяет делимость введенного числа с клавиатуры на 2,3,4,5 СРОЧНО!!!!

Var a:integer;
  flag:boolean;
begin
  flag:=false;
  write(Введите число );
  readln(a);
  if a mod 2 = 0 then  begin
    writeln(Число ,a, делится на 2);
    flag:=true;
  end;
  if a mod 3 = 0 then begin
    writeln(Число ,a, делится на 3);
    flag:=true;
  end;
  if a mod 4 = 0 then  begin
    writeln(Число ,a, делится на 4);
    flag:=true;
  end;
  if a mod 5 = 0 then  begin
    writeln(Число ,a, делится на 5);
    flag:=true;
  end;
  if not flag then writeln(Число ,a, не делится на 2,3,4,5);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку