Номер билета в трамвае состоит из 6 цифр. Счастливым называется билет, сумма первых трех цифр в котором равна сумме последних трех.
Сколько существует счастливых билетов таких, что они состоят только из цифр от 1 до 7
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
var s:=0;
for var d1:=1 to 7 do
for var d2:=1 to 7 do
for var d3:=1 to 7 do
for var d4:=1 to 7 do
for var d5:=1 to 7 do
for var d6:=1 to 7 do
if d1+d2+d3=d4+d5+d6 then Inc(s);
Writeln(Количество билетов ,s);
end.
Результат выполнения программы:
Количество билетов 9331
Оцени ответ
