Даны две дроби А/В и С/D (A,В,C,D — натуральные числа). Составьте программу вычитания из первой дроби второй. Ответ должен быть несократимой дробью. ИСПОЛЬЗОВАТЬ ПОДПРОГРАММУ АЛГОРИТМА ЕВКЛИДА для определения НОД.

// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
function Euclid(a,b:integer):integer;
begin
  while a<>b do if a>b then a-=b else b-=a;
  Result:=a
end;

begin
  var a,b,c,d:integer;
  Write(Числитель и знаменатель первой дроби: );
  Read(a,b);
  Write(Числитель и знаменатель второй дроби: );
  Read(c,d);
  var zn:=b*d;
  var ch:=a*d-c*b;
  var sgn:=Sign(ch); ch:=Abs(ch);
  var gcd:=Euclid(ch,zn);
  Write(Результат вычитания: );
  if sgn=-1 then Write(-);
  Writeln(ch div gcd,/,zn div gcd)
end.

Тестовое решение:
Числитель и знаменатель первой дроби: 7 12
Числитель и знаменатель второй дроби: 3 4
Результат вычитания: -1/6

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку