C++Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет количество трёхзначных чисел в этом массиве, которые не делятся на 5.
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – количество трёхзначных чисел в массиве, которые не делятся на 5.
GNU GCC.
#include
#include
#include
using namespace std;
int main()
{
int a, b, n;
cout <<"Введите границы диапазона и размер массива:" <
if(n>10000) n=10000;
vector
srand(time(0));
cout <<"Исходный массив:" <
v[i] = rand()%(b-a+1) + a;
cout <
cout <<"/n3х-значные элементы, не кратные 5:" <
for (int i=0; i
cout <
return 0;
}
Оцени ответ
