Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль

Var
  n, s: integer;

begin
  write(Число: );
  readln(n);
  s := 0;
  while n > 0 do
  begin
    s := s + n mod 10;
    n := n div 10
  end;
  writeln(Сумма цифр = , s);
end.

Тестовое решение:
Число: 12345
Сумма цифр = 15

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку