Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей. Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

var

  x, y, p, year:integer;

  Summ:real;

begin

  readln(x);

  readln(p);

  readln(y);

  Summ := x;

  year := 0;

  while Summ < y do

  begin

    Summ := (Trunc(Summ * (1 + p / 100) * 100)) / 100;

    year := year + 1;

  end;

  writeln(year);

end.

 

 

// другой вариант

var
  x, y, p, year, Summ:integer;
begin
  readln(x);
  readln(p);
  readln(y);
  Summ := x * 100;
  year := 0;
  while Summ < y * 100 do
  begin
    Summ := Trunc(Summ * (1 + p / 100));
    year := year + 1;
  end;
  writeln(year);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку