Составить программу для вычисления значений функции F(x) на отрезке [a,b] с шагом h.Результат представить в виде таблицы,первый столбец которой-значение аргумента,а второй-соответствующие значения функций.
F(x)=sin²x

Var a,b,h,x,f:real; n,i:integer;
begin
write(a=);readln(a);
write(b=);readln(b);
h:=0.1;
x:=a-h;
n:=round((b-a)/h)+1;
writeln( №   x     f(x));
for i:=1 to n do
begin
 x:=x+h;
 f:=sqr(sin(x));
 writeln(i:2,  ,x:3:1, ,f:8:4);
 end;
end.

Пример:
a=1
b=2
 №   x     f(x)
 1  1.0   0.7081
 2  1.1   0.7943
 3  1.2   0.8687
 4  1.3   0.9284
 5  1.4   0.9711
 6  1.5   0.9950
 7  1.6   0.9991
 8  1.7   0.9834
 9  1.8   0.9484
10  1.9   0.8955
11  2.0   0.8268

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку