Известен периметр равностороннего треугольника написать алгоритм вычисления его высоты и площади,а также длины описанной около него дуги
Var
a, b,p,s,r,h: real;
begin
readln(p);
a:=p/3;
h:=sqrt(sqr(a)-sqr(a/2));
s:=a*h/2;
r:=a/3*sqrt(3);
writeln(высота:, h);
writeln(площадь:, s);
writeln(Длина описанной дуги:,2*pi*r);
end.
Тестовое решение:
15
высота:4.33
площадь:10.82
Длина описанной дуги:18.137
Оцени ответ
