Напишите программу,которая в последовательности натуральных чисел определяет наибольшее число,кратное 3 и оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число,кратное 3 и оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30000.
Программа должна вывести одно число:наибольшее число,кратное 3 и оканчивающееся на 6.
Var a,n,i,max36:integer;
begin
readln(n);
max36:=6;
for i:=1 to n do begin
readln(a);
if (a mod 3 =0) and (a mod 10=6) and (a>max36) then
max36:=a;
end;
writeln(max36);
end.
Тестовое решение:
5
6
36
48
66
124
66
Оцени ответ
