Программу в паскале. Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.
Program foo;
var
b : array[1..10] of integer;
p : longint;
i : byte;
begin
randomize;
for i:=1 to 10 do begin
b[i] := random(51)-25;
write(b[i], );
end;
writeln;
p := 1;
for i:=1 to 10 do
if b[i]>0 then p:= p*b[i];
writeln(p);
end.
Оцени ответ
