Написать программу для решения следующей задачи: найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности. + блок-схема.

Программа:
const n=10;
var a:array[1..n] of integer;
i,max,min:integer; 
begin
Randomize;
writeln(Массив a:);
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
max:=a[1]; min:=a[1];
for i:=1 to n do
  begin
 if a[i]>max then max:=a[i];
 if a[i] end;
writeln(max = ,max,  min = ,min);
writeln(Среднее арифметическое = ,(max+min)/2);
end.

Пример:
Массив a:
  18   8   6  13  15  14  16   6   2  16
max = 18  min = 2
Среднее арифметическое = 10

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку