Составьте программу, заменяющую больше из двух данных чисел удвоенным произведением, а меньшее - полусуммой этих чисел

Var a,b,a1,b1:real;
begin
  readln(a,b);
  if a = b then writeln(Числа равны)
  else
    if a>b then begin
      a1:=2*a*b; b1:=(a+b)/2;
      a:=a1;b:=b1;
      writeln(a = ,a, b = ,b)
    end
    else begin
      b1:=2*a*b; a1:=(a+b)/2;
      a:=a1;b:=b1;
      writeln(a = ,a, b = ,b);
    end;
 end.
 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку