Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип ( равносторонний, равнобедренный, разносторонний)
Var a,b,c : integer;
begin
write(a=); readln(a);
write(b=); readln(b);
write(c=); readln(c);
if (a+b<=c)or(a+c<=b)or(b+c<=a)
then writeln(Треугольника не существует)
else if (a<>b)and(b<>c)and(a<>c)
then writeln(Треугольник разносторонний)
else if (a<>b)or(b<>c) then writeln(Треугольник равнобедренный)
else writeln(Треугольник равносторонний);
end.
Оцени ответ
