Пожалуйста! Напишите программу . Условие такое: вводится дата например 05.04.2016, программа должна вывести что сегодня 5 апреля 2016. Умоляю! Очень нужно!

Программа (не проверяет корректность введенных данных, т.е. работает правильно только в случае, если введена корректная дата в формате dd.mm.yyyy):
const months:array[1..12] of string=
(января,февраля,марта,апреля,мая,июня,
июля,августа,сентября,октября,ноября,декабря);
var s,s1,month:string;
d,m,y,code:integer;
begin
write(Введите дату dd.mm.yyyy = ); readln(s);
Val(copy(s,1,2),d,code);
s1:=s; 
delete(s1,1,3);
Val(copy(s1,1,2),m,code);
month:=months[m];
delete(s1,1,3);
Val(copy(s1,1,4),y,code);
writeln(d, ,month, ,y);
end.

Пример:
Введите дату dd.mm.yyyy = 05.04.2016
5 апреля 2016

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку