Помогите решить
1)Дан массив из 20 элементов заполненный случайными целыми числами из интервала[-10;10].Выведите этот массив в строку и найдите наибольший элемент среди отрицательных элементов массива.
2)Заполнить массив из 15 элементов заполненный случайными целыми числами из интервала от-10 до 10 вывести в строчку ,и повторно вывести в строчку заменив элементы не больше 3 их кубами
PascalABC.NET

1)
const n=20; 
var
  a:array[1..n] of integer;
  i,j,max:integer;
begin
Randomize;
Writeln(Исходный массив:);
for i:=1 to n do begin
  a[i]:=Random(21)-10;
  Write(a[i]:4)
end;
Writeln;
max:=-10;
for i:=1 to n do
 if (a[i]<0)and(a[i]>max) then max:=a[i];
Writeln(max = ,max);
end.

Пример:
Исходный массив:
  10  -8  10  -9   6   7   6   0  -4  10  -3   9   2  10   5   1   8  10   5   4
max = -3

2)
const n=15; 
var
  a:array[1..n] of integer;
  i,j:integer;
begin
Randomize;
Writeln(Исходный массив:);
for i:=1 to n do begin
  a[i]:=Random(21)-10;
  Write(a[i]:6)
end;
Writeln;
for i:=1 to n do
 if a[i]<=3 then a[i]:=a[i]*a[i]*a[i];
Writeln(Измененный массив:);
for i:=1 to n do Write(a[i]:6);
Writeln;
end.

Пример:
Исходный массив:
    -1    -4     9    -2    10    -9     6    -6     5    -1    -2     3     1    -8    10
Измененный массив:
    -1   -64     9    -8    10  -729     6  -216     5    -1    -8    27     1  -512    10

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку