Ниже записан алгоритм.Получив на вход число X, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел X при вводе которого алгоритм печатает сначала 15, а потом 7.
Паскаль
var x, a, b, k : integer;
begin
readln(x) ;
a:=0;
b:=10;
while x>0 do
begin
k:=x mod 10;
a:=a+k;
If k x:=x div 10
end;
writeln(a);
writeln(b);
end.
1. Так как переменная а - число двузначное, то тело цикла будет выполнено дважды.
2. Переменная b = 7 , значит в искомом числе присутствует цифра 7
3. Найдем вторую цифру искомого числа, для этого из переменной а вычтем 7 = 8, так как переменная а в теле цикла увеличивается на остаток от деления на 10 искомого числа.
4. Комбинаций из 8 и 7 всего 2:
78 и 87
Ответ:78
Оцени ответ
