Напишите программы в PASCAL!!!
33. Составьте программу для определения, кто из двух учащихся учится лучше. Фамилии учащихся и их оценки по трем предметам вводить с клавиатуры. Предусмотрите вариант, когда средние баллы одинаковы.
34. Программа запрашивает три числа и выводит на экран разность между максимальным и минимальным числами.

//Задание 33
const
  n = 2;
type
  student = record
    f: string;
    p1, p2, p3: integer;
  end;

var
  a: array[1..n] of student;
  m: array[1..n]of real;
  i: integer;
  s: real;

begin
  s := 0;
  for i := 1 to n do
  begin
    writeln(Введите фамилию , i, ученика );
    readln(a[i].f);
    writeln(оценки по 3 предметам );
    readln(a[i].p1, a[i].p2, a[i].p3);
    if (a[i].p1 + a[i].p2 + a[i].p3) / 3 >= s then begin
      s := (a[i].p1 + a[i].p2 + a[i].p3) / 3;
      m[i] := s;
    end;
  end;
  if m[1] = m[2] then writeln(Средний балл учащихся одинаков)
  else if m[1] > m[2] then
    writeln(a[1].f, учится лучше)
  else  writeln(a[2].f, учится лучше)
end.

Тест №1
Введите фамилию 1 ученика
Иванов
оценки по 3 предметам
3 4 5
Введите фамилию 2 ученика
Петров
оценки по 3 предметам
4 4 4
Средний балл учащихся одинаков

Тест №2
Введите фамилию 1 ученика
Иванов
оценки по 3 предметам
3 4 4
Введите фамилию 2 ученика
Петров
оценки по 3 предметам
5 5 5
Петров учится лучше

//Задание 34
var a,b,c,min,max:integer;
begin
  readln(a,b,c);
  min:=a; max:=a;
  if b  if b>max then max:=b;
  if c  if c>max then max:=c;
  writeln(max-min);
end.




Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку