Напишите программу которая в последовательности натуральных чисел находит среднее арифметическое трехзначный чисел или сообщает,что таких чисел нет

Var
  a,n,s: integer;
begin
//0 - условие окончания ввода последовательности
repeat
  readln(a);
  if (a>99) and (a<1000) then begin
    s:=s+a;n:=n+1;
  end;
  until a = 0;
  if n = 0 then writeln (В последовательности 3-х значных нет)
  else writeln(Среднее арифметическое 3-х значных чисел = ,s/n);
end.

Тест №1
1
5
234
123
5
0
Среднее арифметическое 3-х значных чисел = 178.5

Тест №2
3
5
5678
12
0
В последовательности 3-х значных нет

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку