Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.
//Pascal ABC.NET v3.1 сборка 1172
begin
Var seq:=SeqWhile(ReadInteger(),x -> ReadInteger(),x -> x<>0).ToArray;
writeln(seq.Where(x -> length(inttostr(x))=3).where(x -> x mod 4=0).Count);
end.
Пример ввода:
444
4444
22
123
888
0
Пример вывода:
2
Оцени ответ
