Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.
Var
k, n: integer;
begin
n := 0;
k := 0;
repeat
if (n >= 100) and (n <= 999) and (n mod 4 = 0) then
k := k + 1;
readln(n);
until n = 0;
write(k);
end.
Оцени ответ
