Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0(ноль). Необходимо найти количество чисел у которых количество десятков "4" или "6".
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
n,k,d:integer;
begin
k:=0;
repeat
Write(Введите натуральное число, 0- завершить: );
Read(n);
if n>0 then begin
d:=(n mod 100) div 10;
if (d=4) or (d=6) then Inc(k)
end
until n=0;
Writeln(Искомых чисел - ,k)
end.
Тестовое решение:
Введите натуральное число, 0- завершить: 345
Введите натуральное число, 0- завершить: 6285
Введите натуральное число, 0- завершить: 7854
Введите натуральное число, 0- завершить: 1324
Введите натуральное число, 0- завершить: 653
Введите натуральное число, 0- завершить: 66666
Введите натуральное число, 0- завершить: 0
Искомых чисел - 2
Оцени ответ
