Задача №334. Остаток
Входные данные
Вводятся 4 числа: a, b, c и d.
Выходные данные
Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Примеры
входные данные
2
5
0
2
выходные данные
2 4
входные данные
2
7
9
14
выходные данные
Var
a,b,c,d,x:integer;
begin
read(a,b,c,d);
for x:= a to b do
if x mod d = c then
write(x, );
end.
Оцени ответ
