Паскаль! Помогите пожалуйста составить программу:
1)Вводим любое четырехзначное число. В результате выполнения программы на экране такая запись:
В числе
- тысяч
- сотен
-десятков
- единиц
В скобках <...> указаны переменные, сами скобки обозначают - в этом месте.
2)Ввести с клавиатуры трехзначное число. Определить сумму его цифр (переменная sum) и вывести эти цифры в обратном порядке. В результате выполнения программы на экране такая запись:
В числе
- сотен
-десятков
-единиц
В скобках <...> указаны переменные, сами скобки обозначают - в этом месте
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var n:=ReadInteger(Введите четырехзначное число);
Writeln(В числе);
Writeln(n div 1000, - тысяч);
Writeln((n div 100) mod 10, - сотен);
Writeln((n mod 100) div 10, - десятков);
Writeln(n mod 10, - единиц)
end.
Тестовое решение:
Введите четырехзначное число 4072
В числе
4 - тысяч
0 - сотен
7 - десятков
2 - единиц
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var n:=ReadInteger(Введите трехзначное число);
var s:=n div 100;
var d:=(n div 10) mod 10;
var e:=n mod 10;
Writeln(Sum=,s+d+e);
Writeln(e,d,s);
Writeln(В числе);
Writeln(e, - сотен);
Writeln(d, - десятков);
Writeln(s, - единиц)
end.
Тестовое решение:
Введите трехзначное число 492
Sum=15
294
В числе
2 - сотен
9 - десятков
4 - единиц
