Pascal
Написать программу с использованием цикла с параметром.
Дано целое число n (>0). Найдите произведение 1/6*4/11*...*N^2/(n^2+2n+3) (вещественное число)

/displaystyle /prod_{i=1}^n{/frac{i^2}{n^2+2n+3}}=/prod_{i=1}^n{/frac{i^2}{(i+1)^2+2}}, /quad n /in /mathbb N

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var p:=1.0;
  for var i:=1 to ReadInteger(n=) do
    p*=sqr(i)/(sqr(i+1)+2);
  Writeln(p)
end.

Тестовое решение
n= 10
0.00308222811150801

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку