Даны две последовательности символов A и B одинаковой длины. Напишите программу, которая определяет, можно ли, меняя местами символы в последовательности A, получить из нее последовательность B В С++

#include
#include
#include

using namespace std;

int main() {
int n;
out << "Vvedite n: ";
cin >> n;
vector a(n), b(n);
cout << "Vvedite posl A: ";
for (int i = 0; i < n; ++i) cin >> a[i];
cout << "Vvedite posl B: ";
for (int i = 0; i < n; ++i) cin >> b[i];
sort(a.begin(), a.end());
sort(b.begin(), b.end());
cout << ((a == b) ? "Yes" : "No");
return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку