Помогите пожалуйста составить программу на Паскале, Использовать неравенства x^2 + y^2 < = R^2 если точка принадлежит кругу и x^2 + y^2 > R^2 в противном случае

Var x, y, x1, y1, r: real;
begin
write(Введите координаты точки X, Y: );
read(x, y);
write(Введите координаты центра окружности X, Y: );
read(x1, y1);
write(Введите радиус окружности R: );
read(r);
if sqr(x-x1) + sqr(y-y1) <= r*r then writeln(Точка принадлежит кругу)
else writeln(Точка не принадлежит кругу)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку