Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2+...+X^n и проверьте ее работу при различных значениях X и натурального N

Var
  s, cur: longint;
  x, n, i: integer;
begin
  write(x=); read(x);
  write(n=); read(n);
  cur := 1; s := 0;
  for i := 1 to n do begin
    cur := cur * x; 
    s := s + cur;
  end;
  writeln(sum=, s)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку