Помогите пожалуйста,20 баллов ваши.Даны два числа x,y.Cоставить алгоритм вычисления среднего арифметического S этих чисел,если x меньше y,или их разность R,если y меньше x.

Программу написать? Если да - то я уже тут.
//Язык Pascal

Var x,y,s :longint;
Begin
readln(x,y);
if (xs:= (x + y) div 2
else s:= x-y;
if (x 0 ) then
Writeln(Среднее арифметическое ,x, и ,y, = ,s,,5)
else if (x>=y) then 
Writeln(Разность ,x, и ,y, = ,s)
else Writeln(Среднее арифметическое ,x, и ,y, = ,s);
Readln(x); //Эта строчка нужна, чтобы программа остановилась в конце. Ее можно не писать, если ты не хочешь.
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку