Даны две фамилии. Определить, сколько раз во втором слове встречается первая буква первой фамилии.
Please, нужно написать программу на pascal abc.net, используя служебное слово string.

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadlnString(>).ToWords;
  var c:=UpCase(s[0][1]); // первая буква первого слова
  var w:string:=s[1].ToUpper; // второе слово на верхнем регистре
  var n:=0;
  for var i:=1 to w.Length do
    if Pos(c,w[i])>0 then Inc(n);
  Writeln(Буква ",s[0][1]," встретилась во втором слове ,
    n, раз(а))
end.

Тестовое решение
> Васильев   Воеводченков
Буква "В" встретилась во втором слове 3 раз(а)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку