Помогите с Turbo Pascal.. Надо написать программу
Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10;20]. Вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

Var x: array[1..50] of longint;
var i,a : longint;
Begin
randomize;
for i:= 1 to 50 do
begin;
x[i] := -10 + random(30);
writeln(Элемент №,i, массива Х = ,x[i]);
end;
for i:=1 to 50 do
begin;
if (i mod 2 <> 0) then a:=a+x[i];
end;
Writeln(Сумма элементов с нечетным номером = ,a);
readln(a);
end.

//Я поверил ей на слова, что сумма равна именно такому числу. Если хотите - проверьте.

//Пример работы программы в приложении

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку