ИНФОРМАТИКИ, ПОМОГИТЕ ПОЖАЛУЙСТА
Написать программу решения следующей задачи: Найти целочисленные элементы и номера строк и столбцов, в которых они расположены, для матриц А(5,8); В(6,4). Использовать подпрограмму.
(язык паскаль)
{Предвещая недовольство: мне самому не нравится эта подпрограмма, но динамические массивы обычно не изучают в школьной программе}
//Pascal ABC.NET v3.1 сборка 1219
Const
n1=5;
m1=8;
n2=6;
m2=4;
Type
matrixa=array[1..n1,1..m1] of integer;
matrixb=array[1..n2,1..m2] of integer;
procedure FindInd(f:integer;maa:matrixa;mab:matrixb);
Var i,j:integer;
s:string;
begin
for i:=1 to n1 do
for j:=1 to m1 do
if maa[i,j]=f then s:=s+[+inttostr(i)+][+inttostr(j)+]+chr(10)+chr(13);
writeln(For A:);
writeln(s);
s:=;
for i:=1 to n2 do
for j:=1 to m2 do
if mab[i,j]=f then s:=s+[+inttostr(i)+][+inttostr(j)+]+chr(10)+chr(13);
writeln(For B:);
writeln(s);
end;
Var
maa:matrixa;
mab:matrixb;
i,j,f:integer;
begin
randomize;
writeln(Matrix A:);
for i:=1 to n1 do
begin
for j:=1 to m1 do
begin
maa[i,j]:=random(20);
write(maa[i,j]:4);
end;
writeln;
end;
writeln(Matrix B:);
for i:=1 to n2 do
begin
for j:=1 to m2 do
begin
mab[i,j]:=random(20);
write(mab[i,j]:4);
end;
writeln;
end;
readln(f);
FindInd(f,maa,mab);
end.
Пример ввода:
2
Пример вывода:
Matrix A:
14 10 13 11 6 9 14 9
10 5 12 11 17 5 1 8
4 6 0 19 17 0 1 8
16 13 6 9 15 12 14 18
2 2 15 1 0 7 10 5
Matrix B:
4 9 13 19
13 11 10 2
2 18 9 18
15 2 7 14
9 4 14 13
2 4 13 18
For A:
[5][1]
[5][2]
For B:
[2][4]
[3][1]
[4][2]
[6][1]
