Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом работы программы является последовательность чисел заканчивающихся ( по гипотезе Сиракуза) единицей.

Var
    a, b, n, i: integer;

begin
    readln(a, b);
    for i := a to b do
    begin
        n := i;
        write(n);
        while n <> 1 do
        begin
            if (n mod 2) = 0 then
                n := n div 2
            else
                n := (3 * n + 1) div 2;
            write( -> , n);
        end;
        writeln;
        
    end;
end.

чесно передрано с некого сайта и доработано под задачу

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку