Составьте программу определения наибольшего общего делителя двух натуральных чисел.
на абс паскале плис,.очень надо

Var a,b,NOD:integer;
begin
write(a=); readln(a);
write(b=); readln(b);
while (a<>0)and(b<>0) do
 if a>b then a:=a mod b else b:=b mod a;
NOD:=a+b;
writeln(НОД=,NOD);
end.

Пример:
a=75
b=125
НОД=25

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку