1. Измерение информации. Алфавитный подход
3. Представление чисел и звука в компьютере
5. Хранение информации
7. Написать программу вычисления площади прямоугольника, зная длину и ширину.
9. Напишите программу вычисления площади квадрата, зная его сторону.
11. Найти среднее арифметическое всех положительных чисел массива.
помогите пожалуйста

1) Такой подход к измерению информации не имеет отношения к содержанию текста, поэтому такой способ измерения информации называют объективным. Все символы кодируются одинаковым количеством байт. Количество байт, отводимое под один символ определяется размером алфавита. Пусть в алфавите N букв, а n - количество байт, отводимое под один символ. Тогда n можно найти следующим образом: n - минимальное число такое, что 2^n >= N. Если знаете, что такое логарифм, то n = [logN], где log - двоичный логарифм, а [] - операция округления вверх.

3) Числа хранятся в виде последовательности байт. Пусть для числа отведено n байт. Тогда значения, которые может принимать число - от 0 до 2^n - 1 (если число беззнаковое) или от -2^(n - 1) до 2 ^ (n - 1) - 1 (если число со знаком).

7)
#include using namespace std;
int main(){   int a, b;   cin >> a >> b;   cout << a * b << endl;   return 0;}

9)
#include using namespace std;
int main(){   int a;   cin >> a;   cout << a * a << endl;   return 0;}

11)
#include using namespace std;
int arr[1000];
int main(){   int n;   cin >> n;   for (int i = 0; i < n; ++i)   cin >> arr[i];   int sum = 0, cnt = 0;   for (int i = 0; i < n; ++i)   {     if(arr[i] > 0)     {       sum += arr[i];       ++cnt;     }   }   cout << (float)sum / cnt << endl;   return 0;}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку