Умоляю,помогите составить программу... С клавиатуры одной строкой вводят имя и фамилию через пробел.Составьте программу,которая проверяет,совпадает ли последний символ имени и предпоследний символ фамилии...
Использовать латиницу
#include
using std::cout;
using std::cin;
using std::endl;
#include
using std::strlen;
using std::strtok;
int main()
{
char s[100];
char *temp1;
char *temp2;
cout << "Enter the name and surname: ";
cin.getline(s, 100);
temp1 = strtok(s, " ");
temp2 = strtok(NULL, " ");
if(*(temp1 + strlen(temp1) - 1) == *(temp2 + strlen(temp2) - 2))
{
cout << "true" << endl;
}
else
cout << "false" << endl;
return 0;
}
Оцени ответ
