
Помогите решить, пожалуйста!
Даны значения массива {ai}, i=0,...,10 и переменной х. составьте программу вычисления алгебраического многочлена 10-й степени по формуле Горнера:
а10х в 10 степени+а9хв 10 степени+...+а1х+а0=((...(а10х+а9)х+а8)х+...+а1)х+а0.

Var a:array [0..10] of integer;
i,x:integer; s:real;
begin
writeln(Введите значение x);
readln(x);
writeln(Введите элементы массива);
for i:=0 to 10 do begin
read(a[i]);
s:=s+a[i]*power(x,i);
end;
writeln(s);
end.
Оцени ответ