4. Что будет выведено на экран в результате выполнения инструкции?
a) n :=5;
x :=0;
for i:=1 to n do x: = i;
writeln(x);
b) n: = 1;
while n <= 10 do begin
x: = n*n;
writeln (n : 6, ’ ‘ , x : 6);
end;
c) n : = 0;
repeat
write(‘ * ’);
n : = n + 1;
until n < 5;
5. Чему будет равно значение переменной n после выполнения инструкции?
n:=0;
while n < 5 do
n : = n+1;
6. Для данной инструкции запишите условие окончания цикла так, чтобы цикл завершался, если введено 10 чисел или введенное число 0.
N: = 0;
repeat
write(‘ -> ’);
readln(a);
n: = n+1;
until <условие>;
7. Составьте программу, которая
а) выводит на экран числа от 1 до 10.
б) квадраты нечетных чисел от 7 до 27.
в) квадратные корни из чисел 3, 7, 11, …23.
#4
a)
1
2
3
4
5
b)
1 1
2 4
3 9
4 16
5 25
6 36
7 49
8 64
9 81
10 100
c)
пустой вывод
#5
n = 5
#6
until n > 10 or a == 0
#7
a)
program _1to10;
var
i: integer;
begin
for i := 1 to 10 do
write(i, )
end.
b)
program sqr_7_27;
var
i: integer;
begin
for i := 7 to 27 do
begin
if i mod 2 == 1 then
write(sqr(i), );
end;
end.
c)
program sqrt_3_4per_23;
var
i: integer;
begin
i := 3;
repeat
write(sqrt(i), );
i := i + 4;
until (i > 23);
end.
Оцени ответ
