Написать программу для Pascal.
Вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Var a,b,k1,k2,s:integer; 
begin 
s:=0; 
k1:=0; 
writeln(Введите начало и конец отрезка); 
read(a,b); 
k2:=b-a+1; 
repeat 
if b<0 then break; 
s:=s+b; 
b:=b-1; 
inc(k1); 
until (b=-1) or (b=a-1); 
writeln(Сумма всех целых положительных чисел на отрезке = ,s); 
writeln(Количество отрицательных целых чисел = , k2-k1); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку